Outreach challenges with task completion and prospect removal
Incident Report for Orum
Resolved
We have gotten confirmation from Outreach and believe that this issue has been resolved. If you continue to experience issues, please reach out to our support team at https://support.orum.com and we will be happy to help!
Posted Mar 10, 2023 - 09:29 PST
Monitoring
We have just received word from Outreach support that their engineering team has rolled back a deployment that was released on February 28 in hopes that it will address a bug in play on their end. It is our understanding at this time that the recent change that has been made to Outreach should alleviate the task completion and prospect removal symptoms that were communicated earlier today.

When data from Orum-based calls becomes available after rep call blocks, we would like to request that you evaluate calls with "connect" dispositions that would trigger the removal of a prospect from a sequence. We would expect to see these prospects now being removed from sequences as a result of the bug fix deployed by Outreach.

Should you still be seeing undesired behaviors along this line, please know that we still have an active, escalated ticket with the Outreach support team and can continue to work in partnership with their team to address this ongoing bug.

Thanks very much for your patience and understanding!
Posted Mar 03, 2023 - 09:56 PST
This incident affected: Orum Main App.