We are continuing to monitor the system and no abnormalities have been observed. Thank you
Posted Mar 16, 2026 - 11:54 PDT
Monitoring
A fix has been implemented and we are monitoring system performance to ensure stability. We expect that you can now resume activity within Orum. To ensure your local connection is fully synced with these network changes, you may need to navigate to Personal Settings > System and select Reset Dialing Sessions. We know how important a reliable dialer is to your day and we appreciate your patience while we worked to restore this service. We apologize once again for the disruption.
Posted Mar 16, 2026 - 08:08 PDT
Investigating
We are currently investigating reports of an interruption to dialing services within Orum. Our engineering team is actively researching the root cause of this unexpected behavior with the highest priority to restore full performance. We understand that dialing uptime is critical to your revenue goals and we sincerely apologize for this interruption to your workflow. We will provide another update as soon as more information is available.