Orum Dialer Not Working

Incident Report for Orum

Resolved

This has been resolved. If any users are still experiencing issues with their local system, please reach out to Orum Support. We apologize for the disruption
Posted Sep 11, 2026 - 07:49 PDT

Monitoring

The mitigation has been fully applied and Orum is now working as expected. Our engineering team is actively monitoring the system for stability
Posted Sep 11, 2026 - 07:32 PDT

Identified

The issue has been identified and a remediation measure is being applied
Posted Sep 11, 2026 - 07:26 PDT

Investigating

We are investigating the Orum dialer not working for users
Posted Sep 11, 2026 - 07:24 PDT
This incident affected: Orum services (Dialer).