Salesfloor: Cannot join rooms

Incident Report for Orum

Resolved

The challenge has been resolved and users are able to join Salesfloor rooms as expected.
Posted Apr 04, 2026 - 15:03 PDT

Monitoring

A fix has been implemented and we are monitoring system. Our engineering team has verified that Salesfloor room access has been restored and will continue to observe system metrics.
Posted Apr 04, 2026 - 15:00 PDT

Update

We have identified the cause of the behavior and are currently validating the path forward to address the challenge. We will continue to provide additional updates as research continues.
Posted Apr 04, 2026 - 14:24 PDT

Identified

We have identified the cause of the behavior and are implementing a fix. This is related to a 3rd party API interaction. We are working toward a resolution and will provide further updates as they become available.
Posted Apr 04, 2026 - 13:29 PDT

Investigating

Investigating - We are actively investigating reports of errors when users attempt to join Salesroom rooms within Orum. We will provide more information as soon as it becomes available.
Posted Apr 04, 2026 - 13:26 PDT
This incident affected: Salesfloor.