Slow Loading & Lag on the Dialer Page

Incident Report for Orum

Resolved

Resolved - System metrics have returned to normal. You may resume activity. We will continue to stay engaged and look for further platform optimizations.
Posted May 27, 2026 - 12:03 PDT

Monitoring

Monitoring - A fix has been implemented and we are monitoring system performance to ensure stability. We are seeing modest improvements in platform responsiveness and will continue to review metrics closely as they return to normal levels.
Posted May 27, 2026 - 10:55 PDT

Identified

Identified - We have identified the cause of the behavior and are implementing a fix. Engineering expects the mitigation measure to be live in approximately 30 minutes.
Posted May 27, 2026 - 10:21 PDT

Investigating

Investigating - We are actively investigating reports of intermittent laggy behavior within the Orum platform. Our engineering team is currently researching the root cause of this unexpected symptom to restore optimal performance.
Posted May 27, 2026 - 10:15 PDT
This incident affected: Orum services (Dialer).