Call Failures

Incident Report for Orum

Resolved

The elevated rate of call failures challenge has been resolved. Normal activity in Orum can be resumed, we apologize for the disruption.
Posted Jul 01, 2026 - 20:18 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 01, 2026 - 20:07 PDT

Investigating

We are experiencing an elevated rate of call failures. The engineering team is actively investigating the incident, early findings are pointing towards an issue with our telephony provider.
Posted Jul 01, 2026 - 19:31 PDT
This incident affected: Orum services (Dialer, Salesfloor, Analytics, Coaching suite) and Third-party integrations (Vonage Voice API, HubSpot API).