Orum laggy, unusual dialing behavior
Incident Report for Orum
Resolved
This incident has been resolved.
Posted Oct 26, 2023 - 21:47 PDT
Monitoring
The team is aware of an issue that was affecting Orum functionality and performance. We have taken mitigating actions and believe the system should be behaving normally. Engineering is monitoring the situation and will continue to remediate as needed.
Posted Oct 26, 2023 - 13:29 PDT
This incident affected: Orum Main App.