HubSpot lists unexpectedly capped at 200 prospects

Incident Report for Orum

Resolved

We have identified that recent changes to HubSpot’s integration protocols have introduced a 200-prospect limit per list. We are currently working with HubSpot to address this and explore ways to increase this capacity for your team. We apologize for this inconvenience.
Posted Mar 12, 2026 - 12:45 PDT

Investigating

We are currently investigating reports of a specific behavior affecting HubSpot integrated users where call lists are being capped at 200 prospects within Orum. We understand how critical full list access is to your team's outreach and revenue goals, and our engineering team is treating this investigation with the highest priority. We apologize for this interruption to your workflow.
Posted Mar 12, 2026 - 11:45 PDT
This incident affected: Integration.