Intermittent Analytics Metric Reporting

Incident Report for Orum

Resolved

A correction was made to the intermittently affected records and this is resolved
Posted Jun 24, 2026 - 16:03 PDT

Update

We are continuing to investigate this issue.
Posted Jun 24, 2026 - 10:40 PDT

Investigating

Investigating - We are actively investigating reports of intermittent examples of inaccurate analytics metrics for connects, conversations, and meetings booked within the Orum platform. Our engineering team is currently researching the root cause of this behavior
Posted Jun 24, 2026 - 10:40 PDT
This incident affected: Orum services (Analytics).