Failures dialing in

Incident Report for Orum

Resolved

Confirming this incident is now resolved! We apologize for the inconvenience!
Posted Mar 30, 2026 - 13:23 PDT

Monitoring

The issue has been identified and a fix has been implemented. We are monitoring the system to ensure the full recovery of the service
Posted Mar 30, 2026 - 13:05 PDT

Investigating

Investigating - We are currently investigating reports of a challenge affecting dialing functionality. Users may experience symptoms where calls fail to connect after a single ring. Our engineering team is currently working to identify the root cause of this behavior.
Posted Mar 30, 2026 - 13:00 PDT
This incident affected: Dialer.