Analytics not loading / spinning wheel / query failed

Incident Report for Orum

Resolved

This has been resolved.
Posted Sep 14, 2026 - 14:49 PDT

Update

We are continuing to monitor for any further issues.
Posted Sep 14, 2026 - 14:49 PDT

Monitoring

Monitoring - The third-party provider has restored service, and Orum engineering is actively monitoring system performance to ensure analytics queries load as expected and maintain stability.
Posted Sep 14, 2026 - 14:17 PDT

Identified

Identified - We have identified the cause of the behavior where analytics queries are failing to load across the Orum platform. An underlying third-party application is functioning unexpectedly, preventing queries from completing. We have escalated with their team.
Posted Sep 14, 2026 - 13:48 PDT

Investigating

Investigating - We are actively investigating reports of analytics queries not loading as expected across the Orum platform. Our engineering team is analyzing system metrics to isolate this behavior.
Posted Sep 14, 2026 - 13:18 PDT
This incident affected: Orum services (Analytics).