Intermittent Unable To Dial In

Incident Report for Orum

Resolved

This incident has been resolved.
Posted May 22, 2026 - 07:58 PDT

Update

Monitoring - A fix has been implemented and we are monitoring system performance to ensure stability. Affected users may now click "start session" to resume normal dialing activity on the Orum platform.
Posted May 22, 2026 - 07:46 PDT

Monitoring

A fix has been released and engineering is monitoring for any further issues.
Posted May 22, 2026 - 07:39 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 22, 2026 - 07:38 PDT

Investigating

Our engineering team is aware of an increase in session start timeout errors and currently investigating. We've identified the root cause and are working on a fix.
Posted May 22, 2026 - 07:35 PDT
This incident affected: Orum services (Dialer).