Analytics Not Loading for Some Orgs

Incident Report for Orum

Resolved

This challenge has been resolved.
Posted Sep 08, 2026 - 11:16 PDT

Monitoring

A fix has been implemented and we are monitoring system performance to ensure stability. Rep performance stats within Orum analytics have restored and are functioning as expected across all organizations.
Posted Sep 08, 2026 - 10:17 PDT

Identified

Our team has identified the core of the challenge and is applying a mitigation measure.
Posted Sep 08, 2026 - 10:15 PDT

Investigating

We are investigating reports of rep performance analytics not loading for some orgs
Posted Sep 08, 2026 - 10:12 PDT
This incident affected: Orum services (Analytics).