A fix has been implemented and all system metrics have returned to normal levels. We understand how critical a reliable dialer is to your day and your revenue goals and we deeply apologize for the disruption. We sincerely appreciate your patience while our team worked to resolve this behavior. If you continue to experience any residual symptoms, please reach out to our support team and we will be more than happy to assist further.
Posted Feb 17, 2026 - 09:12 PST
Update
Monitoring - System metrics have returned to normal values and we are monitoring to ensure continued stability. Users should be able to resume normal activity. If you have not already done so, please refresh your Orum webpage and start a new dialing session.
Posted Feb 17, 2026 - 07:52 PST
Monitoring
Monitoring - A fix has been implemented and we are monitoring system performance to ensure stability. Users who were previously experiencing the "The list is currently dialing" symptom should refresh their Orum webpage and start a new dialing session to resume normal activity.
Posted Feb 17, 2026 - 07:09 PST
Identified
Identified - We have identified the cause of the behavior resulting in "The list is currently dialing" messages for users. We are currently implementing a fix across the platform to resolve this symptom and restore normal operation.
Posted Feb 17, 2026 - 06:29 PST
Update
Investigating - We are actively investigating reports of widespread connectivity challenges with the dialer. Our engineering team is currently researching to identify the root cause. We will provide further updates as the investigation progresses.
Posted Feb 17, 2026 - 06:21 PST
Investigating
We are currently investigating reports of the dialer not working as expected.