Intermittent call degradation

Incident Report for Orum

Resolved

We're seeing all traffic flow through normally since AWS marked their outage as resolved.

Moving this incident to resolved as well.

See the AWS health page for more information on their incident https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 16:02 PDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 15:39 PDT

Monitoring

AWS has suffered a critical outage during the overnight hours of 10/20. While they have mitigated the issue in some areas, it is not fully resolved and many ripple effects are still out there.

Orum is not built on AWS, but many of our 3rd party partners are, causing some Orum users to experience sporadic symptoms such as laggy behavior and other unexpected behaviors. These symptoms are caused directly by AWS incident.

Our team is monitoring the matter closely. Please reach out to support.orum.com with any questions or concerns and we will be happy to assist.

If you would like to see the status of the AWS outage, it can be seen here: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 15:38 PDT

Identified

Some customers have reported call failures and delayed connections. We believe this is due to the below AWS outage impacting our telephony service provider and will provide updates as the become available.
Posted Oct 20, 2025 - 08:22 PDT
This incident affected: Dialer.